Paint Shop Pro 5.01


Release Notes











Thank you for purchasing Paint Shop Pro 5! We’ve never before offered a program that contains so many new features, and we’re excited about this release. After you’ve had a chance to try out the program, we think you’ll agree that Paint Shop Pro is now the most versatile image editing solution for graphics presentation in the office, at home, and on the Web.





Please remember that this is a licensed version of Paint Shop Pro and can not be freely distributed. Please see the license agreement that came with this software for limits on copying Paint Shop Pro.
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Changes from Paint Shop Pro 5.0





We have added the following features:





A Brush size control for pressure-sensitive tablets


A Redo command to reapply edits after using the Undo command 


Automatic image scrolling while making Point-to-Point and Smart Edge selections





To improve productivity and efficiency, we have made the following enhancements:





Undo operations are now optimized to save only the portions of an image that have changed. This minimizes the disk space used and increases the overall speed of the Undo operation and the program.


The selected color in the Edit Palette dialog box is always the foreground color


TIFF file format LZW compression produces smaller files while retaining image quality





Based on user input and feedback, we have made the following changes and corrections:





In Windows Explorer, right-clicking a folder and choosing the "Browse with Paint Shop Pro" command opens the Paint Shop Pro Browser, even if the current directory does not contain any readable files.


The Paint Shop Pro Browser reads any root directory, i.e. C: or D:


The Resize and Bicubic resample methods no longer duplicate pixels along the top and right of an image; previously, this resulted in an image shifting down and to the left.


Paint Shop Pro and the Drop Shadow effect from EyeCandy 3.01 work together properly with an 8-bit floating selection (preview) or an 8-bit image (output).


The Text tool accepts larger font sizes.


The Drop Shadow effect functions properly with 8-bit images.


The File Open and Save As dialog boxes automatically correct the extension of file types with multiple extensions.


The Sharpen filter no longer produces a seam in some images.


Selecting Undo after using the Rotate All Layers operation with an active selection now maintains the selection.


After a TIFF Group 4 image has been changed, Paint Shop Pro prompts the user by opening the Save As dialog box instead of automatically saving the image.


New images now display properly in their windows.


Pasting a graphic as a New Selection when the image is zoomed in now centers the cursor and the selection in the image window.


When the Paint Shop Pro program window is maximized, restored, or resized, any minimized image windows now appear within Paint Shop Pro’s workspace.








Changes from Paint Shop Pro 4





One of the most significant changes is the addition of image layers. Layers give you the ability to edit portions of an image without affecting other areas. We have added dozens of other features, including:





Multiple-level Undo / with Undo history


Picture Tube brush


Support for CMYK color separations and output


Explorer-style file Browser


Free-form Deformation tool


Adjustable Crop tool


Additional Retouch brushes


Push brush


Bezier curves


Anti-aliased objects


On-screen grids and rulers


Customized file associations


Increased file format support, including Paint Shop Pro (PSP), 24-bit Amiga (IFF), multi-layer Photoshop (PSD), FlashPix (FPX), Kodak Digital Camera (KDC), Scitex CT (SCT), Pro Photo-CD (PCD), and enhanced metafiles (EMF)


Direct support for Kodak digital cameras


Support for pressure sensitive drawing tablets


Improved TWAIN support


Support for Adobe Photoshop-compatible file format and import/export plug-ins


Monitor gamma correction


Windows 98 and Windows NT 5.0 ICM 2.0 color management





In addition, Paint Shop Pro now includes Animation Shop. Animation Shop is a powerful new way to create and save Animated GIF files for use on the World Wide Web or in multimedia presentations. Animation Shop features include:





Animation Wizard for creating new animations from collections of still images and existing animations


Drawing tools for modifying the frames in an animation


Support for transparency in animations


Configurable Optimization Wizard, giving you precise control over the size of your completed animation


Powerful customizable frame transitions and frame effects


Customizable Text effects


Multiple-level Undo


Cutting and pasting of frames between Animation Shop and Paint Shop Pro


Ability to drag-and-drop frames within and between animations


Intuitive filmstrip-style interface








Paint Shop Pro 4 Users - Frequently Asked Questions





This section is designed to help users familiar with Paint Shop Pro 4 get acquainted with Paint Shop Pro 5.  It addresses some common questions that have been common with users of previous versions.





TWAIN scanning:  The TWAIN Select Source and Acquire command are located under the File menu in the Import > TWAIN submenu.  After Paint Shop Pro starts the data source (your scanner dialog), it remains open, even after a scan.  You must close the data source by selecting the appropriate button or control on the data source’s window.  This change in functionality allows multiple scans to be completed without having to reopen the data source each time.





GIF Transparency:  The method used to create Transparent GIF files has changed considerably from version 4.  To set the transparent color, known and referred to in Paint Shop Pro 5 as “Palette Transparency,” choose Set Palette Transparency from the Colors menu.  If the image you are working on is currently not paletted, you will be prompted to convert the image to 256 colors.  After conversion (if needed), a dialog box that allows you to set the transparent color will open.  Simply move the cursor to the desired color in the image (you will notice your cursor changes to an eye dropper) and click the left mouse button to set the color underneath the dropper to transparent.  To see the effect before committing to the change, click the Proof button.  Press OK to set the selected color to transparent.  If the image needs some touching up, you can actually edit the image with transparency enabled by choosing View Palette Transparency from the Colors menu.  When you are satisfied with the image, open the File menu and choose Save As.  In the file type drop-down list, select “CompuServe GIF” and press OK.





Filling Floating Text:  If you want to fill all the letters of a floating selection created with the Text tool at one time, just change the Flood Fill tool’s Match mode option (on the Tool Controls tab of the Control palette) to “None.” 





Why would you use the new Save Copy As command?  The Save Copy As command was added because most graphic file formats can not hold all the information and complexity contained in an image created in Paint Shop Pro version 5.  The Save Copy As command allows you to save an image file without altering any of your current image’s characteristics.





Basically, Save Copy As allows you to take your wonderful multi-layer creation and save it as a GIF or BMP file without actually changing your image.  The contents of the GIF or BMP file will be limited to what the file format is allowed to contain, but your image will still be as good as it can be.  Here is a sample scenario:  You are asked to create a GIF file for your company’s new Widget Pro web page.  Even though the final result must be a 256-color image, you know that you can create a great 16 million color image, leverage the anti-aliasing and layers of Paint Shop Pro 5, and reduce the color depth as the last step.  You create the image layering in the company logo, the copyright text, a picture of your dog, a nice giant drop-shadowed “Widget” title and so on.  You save the image as a PSP file because you know this is a lossless format that will perfectly preserve all of your layers, selections, attributes, comments, etc.





The next day you want to send a preview of your wonderful creation to your boss for approval, so you perform some last minute clean up, choose Save Copy As from the File menu, select GIF as your file type since this is the file type that that will be needed in the end, and name it “WidTest.GIF”.  Paint Shop Pro automatically does all the work to get your creation into a 256-color GIF file and off you send it.  You can now continue working without reloading your original image because “Save Copy As” did not change your working document in any way.  A “Save As” would have updated your document’s native file type to GIF, file name to “WidTest.GIF” and would have marked the document as “clean” meaning that it will not prompt you to save it.  





Where’s the DPI (dots per inch) setting?  When a file is loaded, the DPI information is read from the file and stored within Paint Shop Pro.  When you save the file, the DPI information is written back out to the file.  DPI information in version 4 was not read from the file, and the numbers specified in the File Preferences dialog were always used when writing files back out.  To change the DPI of a document in Paint Shop Pro 5, choose the Resize command from the Image menu.  Select the “actual / print size” option, and the current DPI settings will be shown.  Change the DPI settings as desired.





Where did Resample go?  Resample is now an option for the Resize command.  Just choose the Resize command from the Image menu.  Near the bottom of the dialog box is a “Resize Type” drop-down list.  The Smart size option will use the best type of resize/resample for your image.  If you wish to choose a specific option, change it in this drop-down list.





How do you set the print size?  Since Paint Shop Pro 5 now handles document DPI, the only size option available in the Print Setup dialog box is scale.  If you wish to change the document’s true physical size, use the Resize command in the Image menu.








Hints for Using Paint Shop Pro 5





You can drag-and-drop thumbnails from the Browser into a document to insert new layers into a document. 


You can drag-and-drop layers from the Layer palette onto a document to copy layers between documents. 


When using the File / Save As command, the image in memory (your current document) will NOT be altered to suit the new image format.  For example, saving a 24-bit image as a GIF file will not cause your 24-bit image in memory to be color reduced to 8-bit.  Of course, the saved GIF file will be 8-bit.


The File / Save As command always defaults to the image’s “native” type and directory.  The File / Save Copy As command remembers the last used type and directory.


The palette transparency options (for formats such as GIF and PNG) are now located under the Colors menu as “Set palette transparency.”


You can <Shift>-Click the New Layer button on the Layer palette to create a new layer without opening the Layer Properties dialog box. 


Use the <Tab> key to hide all floating palettes to make more room for working on images; press the <Tab> key again to restore them. 


You can open a new window of an image at a smaller zoom factor to see a "thumbnail" view when editing details.  Choose the New Window command in the Window menu. All changes will appear in the second window as well as the first. 


Selections can be saved along with an image by saving the selection into an alpha channel.  Multiple alpha channels can be saved into an image, each with its own name.  Masks can also be saved into alpha channels. 


The LZ77 compression option in the Paint Shop Pro file format is completely lossless and can significantly reduce the file size.  This is the only format that will save all document attributes intact. 


Custom brush tips increase the flexibility of the brushes in Paint Shop Pro.  To create or load a custom brush tip, click the Brush Options button on the Brush Tip tab of the Control palette (the brush icon in the upper right) and choose Custom.  If you have a portion of the current image selected, you will be able to save that selection as a new custom brush tip.





Animation Shop – Changes since 1.0


Animation Shop 1.01 and 1.02 include two new transitions:


The underwater transition applies distortion and sunlight reflection so that the image looks as if it is underwater.


The stained glass transition makes the image appear as if it is a stained glass window, with sunlight shining through from behind.





Animation Shop 1.01 mistakenly included unsupported file formats in the open and save file type lists.  These have been removed in Animation Shop 1.02.








Animation Shop – Frequently Asked Questions





Why did my animation file size get larger after optimizing?


After optimizing, the Optimization Wizard shows you the new and the old file sizes.  In some cases, the new size will be larger than the old size.  There are three possible reasons for this:





The animation has changed since it was last saved.  If you open a 10 frame animation and add 100 frames to it, the size of the new 110 frame animation is going to be larger than the original 10 frame animation.


The “Use Transparency to boost compression” optimization is on. This can sometimes make images larger.  You can turn this option off by clicking the “Customize…” button on the optimization wizard quality page.


You used a different dither method. The dither method chosen can have a dramatic effect on file size.  Error diffusion dither gives better color fidelity than nearest color dither, but it results in larger file sizes.





How do I position text precisely?


Animation Shop does not have a way to reposition text after it has been added to a frame.  However, if you need precise control of text position, you can do the following:





Create a new animation that has a transparent canvas and a frame size large enough to hold the text you want to add.


Add the text to the blank frame.


Using the Arrow tool, drag the frame containing the text into the main animation file and position it.





How do I control drag and drop?


There are several keys that can be used to control the behavior of drag-and-drop:





Hold down the <Ctrl> key at the start of a drag operation to change the drag from a move to a copy.  If you don’t hold down the <Ctrl> key, the drag is always a move operation.


Hold down the <Shift> key while dropping to snap the drop location to a grid on the target frame.  When you release the mouse button, the dropped frames will be snapped to the closest spot on a 3x3 grid on the target.


Drop between two frames to insert a new frame(s) at that location.  Drop onto a frame to paste the dropped frame(s) into the drop target.  


You can drag multiple frames simultaneously.


If Propagate Paste is turned on, the drop operation is repeated either until the end of the animation or until a change in selection state is reached.  That is, if dropped into a selection, the paste is repeated until the end of the selection.  If the drop target is not selected, the paste is repeated until the end of the animation or until the first selected frame is reached.





How do I change the time a set of frames is displayed?


Duration is set on a per frame basis.  First, select the frame or frames that you want to change. Next, either choose Frame Properties from the Edit menu or right-click with the mouse and choose Properties from the pop-up menu.  Now enter the time to display each frame, in increments of .01 seconds.  





How do I change the number of times an animation is played?  


From the Edit menu, choose Animation Properties, and click the Looping tab.





Why can’t I see this change in Animation Shop?


The Animation Shop Play (Animation) view repeats the animation continuously for as long as the view is open.





Why don’t I have options for frame size, frame position, and removal methods?


In order to keep your file size as small as possible, these features are automatically determined by the optimizer when an animation is saved as a GIF file. 





How do I make my web page visible behind an animation?


Make sure that the canvas color is set to transparent.  From the Edit menu, choose Animation Properties, click Canvas Color tab, and select a transparent canvas.  You should be able to see the checkerboard background behind the animation wherever you want the web page to be visible.  You can the Eraser or Flood Fill tool to make portions of your animation transparent.





I want to make a transition that runs in reverse; for example, fading in instead of fading out.  How do I do that?


First, create the transition in the normal way.  Then, select these new frames and choose Reverse Frames from the Edit menu.





Can I save my animation as an AVI file?


No. Although this version of Animation Shop does not support saving to an AVI file, it can read them.





Can I edit my animation in Paint Shop Pro?


Yes. Animation Shop can read files saved by Paint Shop Pro, and images can be transferred between the two programs using the Cut and Paste commands.








Paint Shop Pro Application Notes


The following changes were made too late to be included in the written documentation:





When the Deformation tool is active, use the right mouse button to constrain the proportions (width and height) of the selection to their current settings.


In a paletted image (one with 16 to 256 colors), clicking the foreground or background color box opens the Select Color From Palette dialog box, not the Edit Color dialog box. You can not open the Color dialog box from the Select Color From Palette dialog box.


To open the Edit Color dialog box when working with a paletted image, choose the Edit Palette command from the Colors menu. 


When the Edit Palette and Select Color From Palette dialog boxes are open, you can choose colors from any document visible within Paint Shop Pro.  This is also true when the Color and Set Palette Transparency dialog boxes are open.


There is an option to turn off the display of save and image processing confirmation/warning dialog boxes. Select it on the Dialogs and Palette tab of the Paint Shop Pro Preferences dialog box.


If you decrease color depth using the Decrease Color Depth - X Colors function, when the total number of colors is 16 or below, the resulting bit depth will be 4-bits per pixel. When it is 17 or higher, the depth will be 8-bits per pixel.  The number selected is the TOTAL number of colors in the resulting image regardless of the “Include Windows Colors” setting.


The Send command from the File menu sends the image in its native file format whenever possible. It only sends the image as a PSP file if it can’t use the native format.


The Wind deformation from Paint Shop Pro 4 is included in this version.


The Browser does not display RAW format files.


Trying to save a file format that is read-only (CDR, CGM, etc.) will bring up the Save As dialog box.








�
Paint Shop Pro 5 Accelerator (Shortcut) Keys:





Command 	Keyboard Shortcut





File Menu 


New	Ctrl + N 


Open 	Ctrl + O 


Browse 	Ctrl + B 


Save 	Ctrl + S 


Save-As 	F12 


Delete 	Ctrl + Del 


Print 	Ctrl + P 





Edit Menu 


Undo 	Ctrl + Z 


Undo History 	Shift + Ctrl + Z 


Cut 	Ctrl + X 


Copy 	Ctrl + C 


Paste: 	


As New Image 	Ctrl + V 


As New Layer 	Ctrl + L 


As New Selection 	Ctrl + E 


As Transparent Selection 	Shift + Ctrl + E 


Into Selection 	Shift + Ctrl + L 





View Menu 


Full Screen Edit 	Shift + A 


Full Screen Preview 	Shift + Ctrl + A 


Normal Viewing 	Ctrl + Alt + N 


Image Information 	Shift + I 


Grid 	Ctrl + Alt + G 





Image Menu 


Flip 	Ctrl + I 


Mirror 	Ctrl + M 


Rotate 	Ctrl + R 


Resize 	Shift + S 





Colors Menu 


Brightness/Contrast 	Shift + B 


Gamma Correction 	Shift + G 


Highlight/Midtone/Shadow	Shift + M 


Hue/Saturation/Luminance 	Shift + H 


Red/Green/Blue 	Shift + U 


Colorize 	Shift + L 


Posterize 	Shift + Z 


Edit Palette 	Shift + P 


Load Palette 	Shift + O 





Layers Menu 


Select Current Layer 	Ctrl + (layer number) 





Selections Menu 


Select All 	Ctrl + A 


Select None 	Ctrl + D 


From Mask 	Shift + Ctrl + S 


Hide Selection Marquee	Shift + Ctrl + M 


Inverse 	Shift + Ctrl + I 


Promote Layer 	Shift + Ctrl + P 


Float 	Ctrl + F 


Defloat 	Shift + Ctrl + F 





Masks Menu 


Hide All 	Shift + Y 


Invert 	Shift + K 


Edit 	Ctrl + K 


View Mask 	Ctrl + Alt + V 





Capture Menu 


Start 	Shift + C 





Window Menu 


New Window 	Shift + W 


Duplicate 	Shift + D 


Fit To Window 	Ctrl + W 








Paint Shop Pro Browser Menus 





File Menu 


New Folder 	Ctrl + B 


Update Thumbnails 	F5 





View Menu 


Refresh Tree 	Ctrl + F5 





Find Menu 


File Name 	Alt + F3 





ImageFile Menu 


Delete 	Ctrl + Del 





Other 


Center Floating Tool Palettes 	Shift + Ctrl + T 


Hide/Restore all floating palettes 	Tab 


Hide/Restore Histogram 	H 


Hide/Restore Layer palette	L 


Hide/Restore toolbar 	T 


Hide/Restore Controls palette	O 


Step through tools 	Spacebar








Animation Shop Accelerator (Shortcut) Keys:





Command 	Keyboard Shortcut





File Menu 


New	Ctrl + N


Open	Ctrl + O


Save	Ctrl + S


Save As	F12





Edit Menu


Undo	Ctrl + Z


Cut	Ctrl + X


Copy	Ctrl + C


Paste 


As New Frames	Ctrl + V


Into Selected Frames	Ctrl + E





Window Menu


Duplicate	Shift + D








Merging Tube Control Files





If you installed this version of Paint Shop Pro over another version and want to keep tubes you created or changes you made to the tubes in the previous version, you need to merge the new control file and the old backup control file. 





To merge the two files:


Open two instances of WordPad.


In the first instance, open the Tubes.ctl file, which is located in the Paint Shop Pro 5/Tubes folder.  This file is the new control file.  You need to add the new tube and edited tube information to it.


In the second instance, open the Tubes.bak file, which is also located in the Paint Shop Pro 5/Tubes folder. This file is the backup copy of the old control file. It contains the tube file information you need to move to Tubes.ctl.


If you created a tube in the previous version of Paint Shop Pro:


In the Tubes.bak file, copy the information on the tube from the TubeName line through the TubeSelectionMode line, and then paste this data into the Tubes.ctl file.  NOTE: These entries must be inserted alphabetically by TubeName.��If you changed the setting for a tube in the previous version of Paint Shop Pro:


In the Tubes.bak file, copy the information on the tube from the TubeName item through the TubeSelectionMode item, and then paste it over the existing entry in the Tubes.ctl file.


Save the Tubes.ctl file.


Close both instances of WordPad.  After you have checked that the tubes appear properly in the newly installed version of Paint Shop Pro, you can delete the Tubes.bak file.








Technical Support





Technical support for Paint Shop Pro 5 can be obtained from:





USA & Canada


---------


Jasc Software, Inc.


PO Box 44997


Eden Prairie, MN 55344 USA


Voice:	(612) 930-9171 (8am to 6pm US Central Standard Time)


Fax:	(612) 930-9172


Internet:	techsup@jasc.com


Web:	http://www.jasc.com





Australia


---------------------------------------


Communique Software


PO Box 777


Blacktown NSW 2148


Australia


Voice:	+1-800-008-777 (Australia) 


	+ 64 09 5288 700 (New Zealand phone and fax)


Fax:	+61 2 9671 5624


Internet:	support@comm-unique.com.au


Web:	http://www.comm-unique.com.au





New Zealand


---------------------------------------


Communique Software


P.O. Box 25-747 St. Heliers


Auckland New Zealand


Australia


Voice:	+ 64 09 5288 700 


Fax:	+ 64 09 5288 700


Internet:	support@comm-unique.com.au


Web:	http://www.comm-unique.com.au





China


---------------


WinPreTon


7F, No. 20 of New Building, Pan-Yang Rd.


ShangHai


PRC


Voice:


    ShangHai	+86 021-6474-1472


    Beijing	+86 010-6874-8558


Fax:


    ShangHai	+86 021-6471-0555


    Beijing	+86 010-6217-9069


Internet:	support@winpreton.com


Web: 	http://www.winpreton.com.tw





Denmark, Norway, Sweden and Finland


---------------------------------------------------------


Pro Soft


Benlose Skel 4 G


DK-4100 Ringsted


Denmark


Voice:	+45 53-61-90-42


Fax:	+45 53-61-93-91


Internet:	support@prosoft.dk


Web:	http://www.prosoft.dk





Deutschland


--------------------


Redaktionsburo Lakies


Holger Lakies


Dobro 14


29479 Jameln


Germany


Voice:	+49 05864-1328


Fax:	+49 05864-1312


Internet:	verlag @lakies.com


Web:	http://www.jasc.de





France


----------------------------


SARL Edition WSKA


46-48 route de Thionville


57140 WOIPPY


France


Voice:	+33 03.87 30 85 57


Fax :	+33 03.87 32 37 75


Internet:	em@wska.com


Web:	http://www.wska.com





Japan


----------------------------


Personal Data Factory


Shimoueki-cho 451-3,


Isesaki-shi, Gunma-ken


372 Japan


Voice:	+81 270-21-1423


Fax:	+81 270-26-1636


CIS:	101153,21


Internet:	101153.21@compuserve.com


Web:	http://www.pdfc.com





Netherlands


--------------------


BroCo Software


Postbus 446


3760 AK  SOEST


The Netherlands


Voice:	+31 035-6029596


Fax:	+31 035-6014012


Internet:	support@broco.nl


Web:	http://www.broco.nl





Spain


---------------


SRL Ediciones WSKA


c/ Ruiz de Alarcón, 7


28014 Madrid - España


Voice:	+34 (1) 360 51 15


Fax:	+34 (1) 523 36 42


Internet:	spain@wska.com


Web:	http://www.wska.com





Taiwan


---------------


WinPreTon


2F-2, No. 157, TaiLee Street


Taipei, Taiwan, R.O.C.


Voice:	+86 2-336-9388


Fax:	+86 2-308-7280


Internet:	support@winpreton.com


Web:	http://www.winpreton.com.tw





United Kingdom


------------------------


Digital Workshop


19 Parsons Street


Banbury, OXON


OX16 8LY, England


Voice:	+44 1295 273476


Fax:	+44 1295 254590


CIS:	74431,1160


Internet	techsupport@digitalworkshop.co.uk


Web:	http://www.digitalworkshop.co.uk
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